Silverlight Spy is compatible with various Silverlight versions. This page provides detailed information on the supported versions.

Compatibility matrix

The following table presents the compatibility matrix of Silverlight Spy for the various Silverlight versions. The Installed column identifies the Silverlight version that is installed on the machine running Silverlight Spy. The Runtime Version column identifies applications that have been built with that particular Silverlight version.

Silverlight VersionVersion NumberInstalledRuntime Version
Silverlight 1.01.0.20816.0nono
Silverlight 2 RTW2.0.31005.0noyes
Silverlight 2 GDR2.0.40115.0noyes
Silverlight 3 RTW3.0.40624.0noyes
Silverlight 3 GDR 13.0.40723.0noyes
Silverlight 3 GDR 23.0.40818.0noyes
Silverlight 3 GDR 33.0.50106.0noyes
Silverlight 3 Security Update3.0.50611.0noyes
Silverlight 4 RTW4.0.50401.0noyes
Silverlight 4 GDR 04.0.50524.0noyes
Silverlight 4 GDR 14.0.50826.0yesyes
Silverlight 4 GDR 24.0.50917.0yesyes
Silverlight 4 GDR 2.54.0.51204.0yesyes
Silverlight 4 GDR 34.0.60129.0yesyes
Silverlight 4 GDR 44.0.60310.0yesyes
Silverlight 4 GDR 54.0.60531.0yesyes
Silverlight 4 GDR 64.0.60831.0yesyes
Silverlight 55.0.61118.0yesyes
Windows Phone SDK 7.03.7.10218.0yesyes
Windows Phone SDK 7.110.1.40219.209yesyes
Note
Silverlight 1.0 applications are not supported by Silverlight Spy. Silverlight 2 applications are supported but you need to have at least Silverlight 4 GDR 1 installed to spy on Silverlight 2 applications.
Note
Silverlight Spy does not support pre-release versions (beta's and release candidates) of Silverlight or Windows Phone tools.